Troubleshooting Direct Job Cost Import Errors

Derek Torres
Derek Torres
  • Updated

Important Note: The ServiceTrade Accounting Connector (STAC) requires a Premium or Enterprise ServiceTrade Subscription and is a paid add-on. Please contact your ServiceTrade Salesperson or your Account Manager if you want to learn more about STAC.

 

This article will walk you through troubleshooting direct job cost import errors for STAC 300.

How should I correct my rejected Import Direct Cost transactions?

Summary

Imported Direct Cost batch has some rejects, should you import again?

Resolution

  1. Review the Import Journal for the reason for the rejection(s).
  2. Make your corrections to the JCDREJECT.JCD file, and import this file.

Note: JCDREJECT.JCD is the default file name for the reject file.  If you selected a different reject file name when importing, that is the file you will correct and import again.

Direct Costs were imported with an incorrect accounting date in Job Cost

Summary

Direct costs were imported into Job Cost with an incorrect accounting date in the file.

Cause

Entered Incorrect Accounting Date during ServiceTrade Accounting Connector Export

Resolution

Create reversing and correcting import files and import using Tools, Import, Direct Costs:

  1. Create another copy of the original import file and change the accounting date to the correct date.
  2. Import this file with the correct accounting dates using Import Direct Costs as usual.

The Job Cost Import Direct Costs journal prints "Info" and "Totals out of balance"

Summary

Direct Project Cost Imports, the reject journal prints "info" on every line and "Totals out of balance" at the end.

Cause

The import file total debits and total credit do not balance

Resolution

There are two options to correct an out of balance file :

  1. Correct the import file to balance the debit and credit totals
  2. Import an out of balance file
    1. From the Job Cost File menu, select Company Settings, JC Settings.
    2. Click Import and change the Force Zero Proof setting to No.

Error: "Cannot override default cost account" when importing direct costs in Job Cost

Summary

When I try to import my direct costs text file I receive the error:

"Cannot override default cost account"

Cause

An account was retrieved through the specified retrieval method and the setting to not allow override is enabled.

Resolution

You must either remove the debit account from the text file so the retrieved one will be used or change the setting to allow override of the retrieved cost (debit) account.

If you need to change the setting to allow override perform the following:

  1. Click File, Company Settings, JC Settings, GL Entry.
  2. Clear the check box next to Don't allow override.
  3. Click OK twice.

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