Troubleshooting Sage 300 PO Import Errors

Derek Torres
Derek Torres
  • Updated

Important Note: The ServiceTrade Accounting Connector (STAC) requires a Premium or Enterprise ServiceTrade Subscription and is a paid add-on. Please contact your ServiceTrade Salesperson or your Account Manager if you want to learn more about STAC.

Where can I find an example of a Job Cost import commitment file?

There are four types of commitment records that you can import:

  • commitment
  • commitment item
  • commitment change order
  • commitment item change order

The following is some general information about commitment import files. For more detailed information about the import record field requirements, see the Job Cost Help topic "Import commitments file."

  • When you import commitments, the commitment record comes first, followed by the commitment line items.
  • When you import commitment change orders, the commitment change order comes first, followed by the commitment change order items.
  • If the commitment change order is for a commitment that is being imported in this file, the commitment must come first in the file.
  • Any row of an import file that starts with a semi-colon is a comment line. Job Cost ignores these lines when you import.
  • Some columns are a check box. Use a 1 to select the check box. Use a 0 or blank to clear the check box.
  • You can enter the amount of the commitment line item, or you can enter a unit and unit cost to calculate the amount.
  • The job or extra must be set up before the commitment can import, lines will reject if it is not set up.

Review the import file for rejections. In some cases, a single rejection may cause multiple related rejections. For information on rejected entries, see Job Cost Help or the Knowledgebase

Import Commitments do not contain Sales Tax

Cause

Column L on the Excel worksheet is not formatted as a text type column prior to saving as a .csv.

Resolution

In Excel, select column L and format as Text prior to saving your worksheet as a .csv file.

 

Error: "job, extra, cost code or category are incorrectly defined" (when importing commitments)

Cause

There is an Extra in the import file but Tracking Extras is not turned on for the company data folder.

Resolution

  1. Either edit the import file to remove the Extra or turn on Tracking Extras in the company data folder as follows:
  2. Log into Job Cost as the Application Administrator \
  3. Go to Tools, Options and check the Audit Setup Activity box
  4. Click OK to exit
  5. Go to Files, Company Settings, JC Settings
  6. Click the radial button for Tracking Extras
  7. Click Okay to exit
  8. Go to Tools, Options and uncheck the Audit Setup Activity box
  9. Click OK to exit

 

Was this article helpful?

/

Comments

0 comments

Please sign in to leave a comment.